Initial revision
[silc.git] / util / robodoc / configure.in
diff --git a/util/robodoc/configure.in b/util/robodoc/configure.in
new file mode 100644 (file)
index 0000000..6c0f5af
--- /dev/null
@@ -0,0 +1,29 @@
+dnl Process this file with autoconf to produce a configure script.
+
+AC_INIT(Source/robodoc.h)
+
+AM_CONFIG_HEADER(Source/config.h)
+
+AM_INIT_AUTOMAKE(robodoc, 3.2.3)
+
+AC_PROG_MAKE_SET
+
+dnl Checks for programs.
+AC_PROG_CC
+
+dnl Checks for libraries.
+
+dnl Checks for header files.
+AC_HEADER_STDC
+
+dnl Checks for typedefs, structures, and compiler characteristics.
+AC_C_CONST
+AC_TYPE_SIZE_T
+
+dnl Checks for library functions.
+AC_FUNC_STRFTIME
+AC_FUNC_VPRINTF
+AC_CHECK_FUNCS(strstr)
+
+AC_OUTPUT(makefile Docs/makefile Source/makefile)
+