Merge branch 'topic/mm-fixes' of git://208.110.73.182/silc into silc.1.1.branch
[silc.git] / lib / silcutil / tests / Makefile.am
index bc97af95d794690fd4129ab63ec055c1ec2e177c..f08893d7250f48d83332f6ade8b81ce11f9fe098 100644 (file)
@@ -19,7 +19,8 @@ AUTOMAKE_OPTIONS = 1.0 no-dependencies foreign
 
 bin_PROGRAMS =         test_silcstrutil test_silcstringprep test_silchashtable \
        test_silclist test_silcfsm test_silcasync test_silcschedule \
-       test_silcnet test_silcstack test_silcmime
+       test_silcnet test_silcstack test_silcmime test_silcfdstream \
+       test_silcatomic test_silcmutex test_silctime
 
 test_silcstrutil_SOURCES = test_silcstrutil.c
 test_silcstringprep_SOURCES = test_silcstringprep.c
@@ -31,6 +32,10 @@ test_silcasync_SOURCES = test_silcasync.c
 test_silcschedule_SOURCES = test_silcschedule.c
 test_silcnet_SOURCES = test_silcnet.c
 test_silcstack_SOURCES = test_silcstack.c
+test_silcfdstream_SOURCES = test_silcfdstream.c
+test_silcatomic_SOURCES = test_silcatomic.c
+test_silcmutex_SOURCES = test_silcmutex.c
+test_silctime_SOURCES = test_silctime.c
 
 LIBS = $(SILC_COMMON_LIBS)
 LDADD = -L.. -L../.. -lsilc