updates.
[silc.git] / lib / silcutil / Makefile.am
index f1040de51b1bf77e3f7e95c8da0011871447f2ec..e2de4414ed19909264b2d6b0a5c08a66e08242d6 100644 (file)
 
 AUTOMAKE_OPTIONS = 1.0 no-dependencies foreign
 
+if SILC_WIN32
+SUBDIRS=win32
+else
+SUBDIRS=unix
+endif
+
 noinst_LIBRARIES = libsilcutil.a
 
 libsilcutil_a_SOURCES = \
@@ -27,11 +33,27 @@ libsilcutil_a_SOURCES = \
        silcmemory.c \
        silcnet.c \
        silcschedule.c \
-       silctask.c \
        silcutil.c \
-       silchashtable.c
+       silchashtable.c \
+       silcsockconn.c  \
+       silcprotocol.c
 
-EXTRA_DIST = *.h
+include_HEADERS =      \
+       silcbuffer.h    \
+       silcbuffmt.h    \
+       silcbufutil.h   \
+       silcconfig.h    \
+       silchashtable.h \
+       silclog.h       \
+       silcmemory.h    \
+       silcmutex.h     \
+       silcnet.h       \
+       silcschedule.h  \
+       silcsockconn.h  \
+       silcprotocol.h  \
+       silcthread.h    \
+       silcutil.h
 
-include $(top_srcdir)/Makefile.defines
+EXTRA_DIST = *.h
 
+include $(top_srcdir)/Makefile.defines.in