Added stacktrace support with --enable-stack-trace option.
[silc.git] / lib / silcutil / Makefile.am
index 07fb94619bb4d008c72a9fc45fa7446a6a6ff5ad..b91e5c5d1b60515344246704c65e6f22caf95376 100644 (file)
@@ -23,9 +23,17 @@ else
 if SILC_EPOC
 SUBDIRS=epoc
 else
+if SILC_BEOS
+SUBDIRS=beos
+else
+if SILC_OS2
+SUBDIRS=os2
+else
 SUBDIRS=unix
 endif
 endif
+endif
+endif
 
 noinst_LIBRARIES = libsilcutil.a
 
@@ -36,16 +44,18 @@ libsilcutil_a_SOURCES = \
        silcmemory.c \
        silcnet.c \
        silcschedule.c \
+       silcfileutil.c \
+       silcstrutil.c \
        silcutil.c \
        silchashtable.c \
        silcsockconn.c  \
-       silcprotocol.c
+       silcprotocol.c  \
+       stacktrace.c
 
 if SILC_DIST_TOOLKIT
 include_HEADERS =      \
        silcbuffer.h    \
        silcbuffmt.h    \
-       silcbufutil.h   \
        silcconfig.h    \
        silchashtable.h \
        silclog.h       \
@@ -58,7 +68,10 @@ include_HEADERS =    \
        silcthread.h    \
        silclist.h      \
        silcdlist.h     \
-       silcutil.h
+       silcfileutil.h  \
+       silcutil.h      \
+       silcstrutil.h   \
+       silctypes.h
 endif
 
 EXTRA_DIST = *.h