updates
[silc.git] / lib / silcutil / Makefile.am
index e016899336838b3b75dcc5a9e46c770df6605859..af1f7fb74c0a0426d9b9a3c6ec1ced7dd18cd0fe 100644 (file)
@@ -35,8 +35,10 @@ libsilcutil_a_SOURCES = \
        silcschedule.c \
        silcutil.c \
        silchashtable.c \
-       silcsockconn.c
+       silcsockconn.c  \
+       silcprotocol.c
 
+if SILC_DIST_TOOLKIT
 include_HEADERS =      \
        silcbuffer.h    \
        silcbuffmt.h    \
@@ -49,8 +51,12 @@ include_HEADERS =    \
        silcnet.h       \
        silcschedule.h  \
        silcsockconn.h  \
+       silcprotocol.h  \
        silcthread.h    \
+       silclist.h      \
+       silcdlist.h     \
        silcutil.h
+endif
 
 EXTRA_DIST = *.h