updates
[silc.git] / lib / silcutil / Makefile.am
index 161f04712922c77a157843affe375efab809d323..af1f7fb74c0a0426d9b9a3c6ec1ced7dd18cd0fe 100644 (file)
@@ -32,12 +32,13 @@ libsilcutil_a_SOURCES = \
        silclog.c \
        silcmemory.c \
        silcnet.c \
-       silctask.c \
        silcschedule.c \
        silcutil.c \
        silchashtable.c \
-       silcsockconn.c
+       silcsockconn.c  \
+       silcprotocol.c
 
+if SILC_DIST_TOOLKIT
 include_HEADERS =      \
        silcbuffer.h    \
        silcbuffmt.h    \
@@ -50,9 +51,12 @@ include_HEADERS =    \
        silcnet.h       \
        silcschedule.h  \
        silcsockconn.h  \
-       silctask.h      \
+       silcprotocol.h  \
        silcthread.h    \
+       silclist.h      \
+       silcdlist.h     \
        silcutil.h
+endif
 
 EXTRA_DIST = *.h