updates.
[silc.git] / lib / silcutil / Makefile.am
index 93cd4a3b2591e883b0d9eb627ba7de8961af91f9..ac4e73e0d7cca1997c143ebce0ec5c0a4d3d916d 100644 (file)
@@ -1,14 +1,13 @@
 #
 #  Makefile.am
 #
-#  Author: Pekka Riikonen <priikone@poseidon.pspt.fi>
+#  Author: Pekka Riikonen <priikone@silcnet.org>
 #
-#  Copyright (C) 2000 Pekka Riikonen
+#  Copyright (C) 2000 - 2002 Pekka Riikonen
 #
 #  This program is free software; you can redistribute it and/or modify
 #  it under the terms of the GNU General Public License as published by
-#  the Free Software Foundation; either version 2 of the License, or
-#  (at your option) any later version.
+#  the Free Software Foundation; version 2 of the License.
 #
 #  This program is distributed in the hope that it will be useful,
 #  but WITHOUT ANY WARRANTY; without even the implied warranty of
@@ -21,8 +20,12 @@ AUTOMAKE_OPTIONS = 1.0 no-dependencies foreign
 if SILC_WIN32
 SUBDIRS=win32
 else
+if SILC_EPOC
+SUBDIRS=epoc
+else
 SUBDIRS=unix
 endif
+endif
 
 noinst_LIBRARIES = libsilcutil.a
 
@@ -33,6 +36,7 @@ libsilcutil_a_SOURCES = \
        silcmemory.c \
        silcnet.c \
        silcschedule.c \
+       silcfileutil.c \
        silcutil.c \
        silchashtable.c \
        silcsockconn.c  \
@@ -42,7 +46,6 @@ if SILC_DIST_TOOLKIT
 include_HEADERS =      \
        silcbuffer.h    \
        silcbuffmt.h    \
-       silcbufutil.h   \
        silcconfig.h    \
        silchashtable.h \
        silclog.h       \
@@ -53,6 +56,9 @@ include_HEADERS =     \
        silcsockconn.h  \
        silcprotocol.h  \
        silcthread.h    \
+       silclist.h      \
+       silcdlist.h     \
+       silcfileutil.h  \
        silcutil.h
 endif