Added cross-reference support for document generator.
[silc.git] / lib / silcutil / Makefile.am
index 07fb94619bb4d008c72a9fc45fa7446a6a6ff5ad..5b7f020e0d5aef7749c220f1dfdc74769d2222c2 100644 (file)
@@ -23,9 +23,17 @@ else
 if SILC_EPOC
 SUBDIRS=epoc
 else
+if SILC_BEOS
+SUBDIRS=beos
+else
+if SILC_OS2
+SUBDIRS=os2
+else
 SUBDIRS=unix
 endif
 endif
+endif
+endif
 
 noinst_LIBRARIES = libsilcutil.a
 
@@ -36,6 +44,7 @@ libsilcutil_a_SOURCES = \
        silcmemory.c \
        silcnet.c \
        silcschedule.c \
+       silcfileutil.c \
        silcutil.c \
        silchashtable.c \
        silcsockconn.c  \
@@ -45,7 +54,6 @@ if SILC_DIST_TOOLKIT
 include_HEADERS =      \
        silcbuffer.h    \
        silcbuffmt.h    \
-       silcbufutil.h   \
        silcconfig.h    \
        silchashtable.h \
        silclog.h       \
@@ -58,7 +66,9 @@ include_HEADERS =     \
        silcthread.h    \
        silclist.h      \
        silcdlist.h     \
-       silcutil.h
+       silcfileutil.h  \
+       silcutil.h      \
+       silctypes.h
 endif
 
 EXTRA_DIST = *.h