Merged silc_1_0_branch to trunk.
[silc.git] / lib / silcutil / Makefile.ad
similarity index 81%
rename from lib/silcutil/Makefile.am
rename to lib/silcutil/Makefile.ad
index b5530d6ef12ab0253af28a9fc04c188475c65525..c9ba5f61ffb1a1a2abb83ba1fda97779d27bf487 100644 (file)
@@ -1,9 +1,9 @@
 #
-#  Makefile.am
+#  Makefile.ad
 #
 #  Author: Pekka Riikonen <priikone@silcnet.org>
 #
-#  Copyright (C) 2000 - 2002 Pekka Riikonen
+#  Copyright (C) 2000 - 2005 Pekka Riikonen
 #
 #  This program is free software; you can redistribute it and/or modify
 #  it under the terms of the GNU General Public License as published by
@@ -35,13 +35,12 @@ endif
 endif
 endif
 
-if SILC_DIST_TOOLKIT
+DIST_SUBDIRS=win32 epoc beos os2 unix
+
+#ifdef SILC_DIST_TOOLKIT
 SILC_DIST_SOURCE = stacktrace.c
 SILC_DIST_HEADER = stacktrace.h
-else
-SILC_DIST_SOURCE =
-SILC_DIST_HEADER =
-endif
+#endif SILC_DIST_TOOLKIT
 
 noinst_LTLIBRARIES = libsilcutil.la
 
@@ -60,9 +59,11 @@ libsilcutil_la_SOURCES = \
        silcsockconn.c  \
        silcprotocol.c  \
        silcvcard.c     \
-       silcapputil.c
+       silcapputil.c   \
+       silcutf8.c      \
+       silcstringprep.c
 
-if SILC_DIST_TOOLKIT
+#ifdef SILC_DIST_TOOLKIT
 include_HEADERS =      \
        $(SILC_DIST_HEADER) \
        silcbuffer.h    \
@@ -84,9 +85,13 @@ include_HEADERS =    \
        silcstrutil.h   \
        silcvcard.h     \
        silcapputil.h   \
+       silcutf8.h      \
+       silcstringprep.h        \
        silctypes.h
-endif
 
-EXTRA_DIST = *.h
+SILC_EXTRA_DIST = tests
+#endif SILC_DIST_TOOLKIT
+
+EXTRA_DIST = *.h $(SILC_EXTRA_DIST)
 
 include $(top_srcdir)/Makefile.defines.in