Merged silc_1_0_branch to trunk.
[silc.git] / lib / silcmath / Makefile.ad
similarity index 75%
rename from lib/silcmath/Makefile.am
rename to lib/silcmath/Makefile.ad
index 4dec62ac8500d3c05e8ac9cd65827e357d2b64f8..a65c9d88f9dceb8e777f30e090eb39172868001e 100644 (file)
@@ -1,14 +1,13 @@
 #
-#  Makefile.am
+#  Makefile.ad
 #
-#  Author: Pekka Riikonen <priikone@poseidon.pspt.fi>
+#  Author: Pekka Riikonen <priikone@silcnet.org>
 #
-#  Copyright (C) 2000 Pekka Riikonen
+#  Copyright (C) 2000 - 2005 Pekka Riikonen
 #
 #  This program is free software; you can redistribute it and/or modify
 #  it under the terms of the GNU General Public License as published by
-#  the Free Software Foundation; either version 2 of the License, or
-#  (at your option) any later version.
+#  the Free Software Foundation; version 2 of the License.
 #
 #  This program is distributed in the hope that it will be useful,
 #  but WITHOUT ANY WARRANTY; without even the implied warranty of
@@ -24,18 +23,14 @@ else
 SUBDIRS =
 endif
 
+DIST_SUBDIRS = mpi
+
 noinst_LTLIBRARIES = libsilcmath.la
 
 if SILC_MP_NSS_MPI
 MP_SOURCE = mp_mpi.c
-if SILC_DIST_TOOLKIT
-MP_HEADER = mpi/mpi.h mpi/mplogic.h mpi/mpi-config.h
-else
-MP_HEADER =
-endif
 else
 MP_SOURCE = mp_gmp.c
-MP_HEADER =
 endif
 
 libsilcmath_la_SOURCES = \
@@ -44,14 +39,15 @@ libsilcmath_la_SOURCES = \
        mpbin.c \
        $(MP_SOURCE)
 
-if SILC_DIST_TOOLKIT
+#ifdef SILC_DIST_TOOLKIT
+MP_HEADER = mpi/mpi.h mpi/mplogic.h mpi/mpi-config.h
 include_HEADERS =      \
        mp_gmp.h        \
        mp_mpi.h        \
        silcmath.h      \
        silcmp.h        \
        $(MP_HEADER)
-endif
+#endif SILC_DIST_TOOLKIT
 
 EXTRA_DIST = mp_gmp.c mp_mpi.c *.h