Added SILC Thread Queue API
[silc.git] / lib / silccrypt / tests / Makefile.am
index e2aa13178ae8660290ad9f59632a6737caab48b0..838a57c3c10112f06b44ab1f0d95edf571d80f53 100644 (file)
@@ -3,7 +3,7 @@
 #
 #  Author: Pekka Riikonen <priikone@silcnet.org>
 #
-#  Copyright (C) 2002 Pekka Riikonen
+#  Copyright (C) 2002 - 2003 Pekka Riikonen
 #
 #  This program is free software; you can redistribute it and/or modify
 #  it under the terms of the GNU General Public License as published by
 AUTOMAKE_OPTIONS = 1.0 no-dependencies foreign
 
 bin_PROGRAMS =         test_sha1       \
+               test_sha256     \
                test_md5        \
                test_hmacsha1   \
+               test_hmacsha256 \
                test_hmacmd5    \
                test_aes        \
-               test_twofish
+               test_twofish    \
+               test_cast5      \
+               test_des        \
+               test_silcpkcs   \
+               test_dsa        \
+               test_hash
 
+test_hash_SOURCES = test_hash.c
 test_sha1_SOURCES = test_sha1.c
+test_sha256_SOURCES = test_sha256.c
 test_md5_SOURCES = test_md5.c
 test_hmacsha1_SOURCES = test_hmacsha1.c
+test_hmacsha256_SOURCES = test_hmacsha256.c
 test_hmacmd5_SOURCES = test_hmacmd5.c
 
 test_aes_SOURCES = test_aes.c
-test_twofish_SOURCES = test_aes.c
+test_twofish_SOURCES = test_twofish.c
+test_cast5_SOURCES = test_cast5.c
+test_des_SOURCES = test_des.c
+
+test_silcpkcs_SOURCES = test_silcpkcs.c
+test_dsa_SOURCES = test_dsa.c
 
 LIBS = $(SILC_COMMON_LIBS)
 LDADD = -L.. -L../.. -lsilc