updates.
[silc.git] / lib / silccrypt / Makefile.am
index b0d7d8185ab09bc745be1f5f546dc98ee91071a6..e55cb151c4197e0f1ec814bc0df0885058e9b4ca 100644 (file)
@@ -22,23 +22,45 @@ noinst_LIBRARIES = libsilccrypt.a
 
 libsilccrypt_a_SOURCES = \
        none.c \
-       blowfish.c \
        rc5.c \
        rc6.c \
        mars.c \
        md5.c \
-       rijndael.c \
+       aes.c \
        rsa.c \
        sha1.c \
        twofish.c \
+       blowfish.c \
+       cast.c \
        silccipher.c \
        silchash.c \
        silchmac.c \
        silcrng.c \
-       silcpkcs.c
+       silcpkcs.c \
+       pkcs1.c
+
+include_HEADERS =      \
+       aes.h           \
+       blowfish.h      \
+       cast.h          \
+       ciphers_def.h   \
+       ciphers.h       \
+       mars.h          \
+       md5.h           \
+       none.h          \
+       pkcs1.h         \
+       rc5.h           \
+       rc6.h           \
+       rsa.h           \
+       sha1.h          \
+       silccipher.h    \
+       silcdh.h        \
+       silchash.h      \
+       silchmac.h      \
+       silcpkcs.h      \
+       silcrng.h       \
+       twofish.h
 
 EXTRA_DIST = *.h
 
-INCLUDES = -I. -I.. -I../silccore -I../silcmath -I../silcske \
-       -I../silcsim -I../.. -I../../includes \
-       -I../silcmath/gmp-3.0.1
+include $(top_srcdir)/Makefile.defines.in