updates.
[silc.git] / lib / silccrypt / Makefile.am
index 741b1dc05e90369dd66ad26519596de095978ec9..e55cb151c4197e0f1ec814bc0df0885058e9b4ca 100644 (file)
@@ -30,6 +30,8 @@ libsilccrypt_a_SOURCES = \
        rsa.c \
        sha1.c \
        twofish.c \
+       blowfish.c \
+       cast.c \
        silccipher.c \
        silchash.c \
        silchmac.c \
@@ -37,8 +39,28 @@ libsilccrypt_a_SOURCES = \
        silcpkcs.c \
        pkcs1.c
 
+include_HEADERS =      \
+       aes.h           \
+       blowfish.h      \
+       cast.h          \
+       ciphers_def.h   \
+       ciphers.h       \
+       mars.h          \
+       md5.h           \
+       none.h          \
+       pkcs1.h         \
+       rc5.h           \
+       rc6.h           \
+       rsa.h           \
+       sha1.h          \
+       silccipher.h    \
+       silcdh.h        \
+       silchash.h      \
+       silchmac.h      \
+       silcpkcs.h      \
+       silcrng.h       \
+       twofish.h
+
 EXTRA_DIST = *.h
 
-INCLUDES = -I. -I.. -I../silccore -I../silcmath -I../silcske \
-       -I../silcsim -I../.. -I../silcutil -I../../includes \
-       -I../silcmath/gmp -I../trq
+include $(top_srcdir)/Makefile.defines.in