Fixed the libtoolfix to use command line arguments.
[silc.git] / lib / silccrypt / Makefile.am
index e2522d889f575d345642559f6c8b1e49f71d6c55..d158c3ae20fc8d072b2b1ba71b7f84a688c30aeb 100644 (file)
@@ -20,9 +20,6 @@ AUTOMAKE_OPTIONS = 1.0 no-dependencies foreign
 
 noinst_LTLIBRARIES = libsilccrypt.la
 
-# Compile silccrypt always as shared library since silcsim will need it.
-LIBTOOL_ENABLE_SHARED=yes
-
 libsilccrypt_la_SOURCES = \
        none.c \
        rc5.c \
@@ -41,6 +38,9 @@ libsilccrypt_la_SOURCES = \
        silcpkcs.c \
        pkcs1.c
 
+# Tell libtool to compile silccrypt as shared since silcsim will need it.
+CFLAGS = --libtool-enable-shared
+
 if SILC_DIST_TOOLKIT
 include_HEADERS =      \
        aes.h           \
@@ -64,6 +64,6 @@ include_HEADERS =     \
        twofish.h
 endif
 
-EXTRA_DIST = *.h
+EXTRA_DIST = *.h tests
 
 include $(top_srcdir)/Makefile.defines.in