Merged from silc_1_0_branch.
[silc.git] / lib / silccrypt / Makefile.am
index e55cb151c4197e0f1ec814bc0df0885058e9b4ca..47f7204491e8e6810f2b9556744055b1bb07944b 100644 (file)
 
 AUTOMAKE_OPTIONS = 1.0 no-dependencies foreign
 
-noinst_LIBRARIES = libsilccrypt.a
+noinst_LTLIBRARIES = libsilccrypt.la
 
-libsilccrypt_a_SOURCES = \
+libsilccrypt_la_SOURCES = \
        none.c \
        rc5.c \
        rc6.c \
-       mars.c \
        md5.c \
        aes.c \
        rsa.c \
@@ -39,13 +38,22 @@ libsilccrypt_a_SOURCES = \
        silcpkcs.c \
        pkcs1.c
 
+if SILC_LIBTOOLFIX
+# Tell libtool to compile silccrypt as shared since silcsim will need it.
+LTFLAGS = --libtool-enable-shared
+else
+LTFLAGS = 
+endif
+
+CFLAGS = $(LTFLAGS)
+
+if SILC_DIST_TOOLKIT
 include_HEADERS =      \
        aes.h           \
        blowfish.h      \
        cast.h          \
        ciphers_def.h   \
        ciphers.h       \
-       mars.h          \
        md5.h           \
        none.h          \
        pkcs1.h         \
@@ -60,7 +68,8 @@ include_HEADERS =     \
        silcpkcs.h      \
        silcrng.h       \
        twofish.h
+endif
 
-EXTRA_DIST = *.h
+EXTRA_DIST = *.h tests
 
 include $(top_srcdir)/Makefile.defines.in