Merged from silc_1_0_branch.
[silc.git] / lib / silccrypt / Makefile.am
index c3f058f0af2a5d4583b08ceb95074e02fe4c7f08..47f7204491e8e6810f2b9556744055b1bb07944b 100644 (file)
@@ -38,6 +38,15 @@ libsilccrypt_la_SOURCES = \
        silcpkcs.c \
        pkcs1.c
 
+if SILC_LIBTOOLFIX
+# Tell libtool to compile silccrypt as shared since silcsim will need it.
+LTFLAGS = --libtool-enable-shared
+else
+LTFLAGS = 
+endif
+
+CFLAGS = $(LTFLAGS)
+
 if SILC_DIST_TOOLKIT
 include_HEADERS =      \
        aes.h           \
@@ -61,6 +70,6 @@ include_HEADERS =     \
        twofish.h
 endif
 
-EXTRA_DIST = *.h
+EXTRA_DIST = *.h tests
 
 include $(top_srcdir)/Makefile.defines.in