Merged from silc_1_0_branch.
[silc.git] / lib / silccrypt / Makefile.am
index 5bd1be0a21d6d274d3c33a0b0841a2e103a30117..47f7204491e8e6810f2b9556744055b1bb07944b 100644 (file)
@@ -24,7 +24,6 @@ libsilccrypt_la_SOURCES = \
        none.c \
        rc5.c \
        rc6.c \
-       mars.c \
        md5.c \
        aes.c \
        rsa.c \
@@ -39,6 +38,15 @@ libsilccrypt_la_SOURCES = \
        silcpkcs.c \
        pkcs1.c
 
+if SILC_LIBTOOLFIX
+# Tell libtool to compile silccrypt as shared since silcsim will need it.
+LTFLAGS = --libtool-enable-shared
+else
+LTFLAGS = 
+endif
+
+CFLAGS = $(LTFLAGS)
+
 if SILC_DIST_TOOLKIT
 include_HEADERS =      \
        aes.h           \
@@ -46,7 +54,6 @@ include_HEADERS =     \
        cast.h          \
        ciphers_def.h   \
        ciphers.h       \
-       mars.h          \
        md5.h           \
        none.h          \
        pkcs1.h         \
@@ -63,6 +70,6 @@ include_HEADERS =     \
        twofish.h
 endif
 
-EXTRA_DIST = *.h
+EXTRA_DIST = *.h tests
 
 include $(top_srcdir)/Makefile.defines.in