Merged silc_1_0_branch to trunk.
[silc.git] / lib / silccrypt / Makefile.ad
similarity index 81%
rename from lib/silccrypt/Makefile.am
rename to lib/silccrypt/Makefile.ad
index 3dd281ca453b60687de3d847b636417272633bcf..c5b3a112bcf1391a79a03c5fd5e1cb0cc92e7e86 100644 (file)
@@ -1,14 +1,13 @@
 #
-#  Makefile.am
+#  Makefile.ad
 #
-#  Author: Pekka Riikonen <priikone@poseidon.pspt.fi>
+#  Author: Pekka Riikonen <priikone@silcnet.org>
 #
-#  Copyright (C) 2000 Pekka Riikonen
+#  Copyright (C) 2000 - 2005 Pekka Riikonen
 #
 #  This program is free software; you can redistribute it and/or modify
 #  it under the terms of the GNU General Public License as published by
-#  the Free Software Foundation; either version 2 of the License, or
-#  (at your option) any later version.
+#  the Free Software Foundation; version 2 of the License.
 #
 #  This program is distributed in the hope that it will be useful,
 #  but WITHOUT ANY WARRANTY; without even the implied warranty of
@@ -23,7 +22,6 @@ noinst_LTLIBRARIES = libsilccrypt.la
 libsilccrypt_la_SOURCES = \
        none.c \
        rc5.c \
-       rc6.c \
        md5.c \
        aes.c \
        rsa.c \
@@ -36,18 +34,18 @@ libsilccrypt_la_SOURCES = \
        silchmac.c \
        silcrng.c \
        silcpkcs.c \
-       pkcs1.c
+       silcpkcs1.c
 
 if SILC_LIBTOOLFIX
 # Tell libtool to compile silccrypt as shared since silcsim will need it.
 LTFLAGS = --libtool-enable-shared
 else
-LTFLAGS = 
+LTFLAGS =
 endif
 
 CFLAGS = $(LTFLAGS)
 
-if SILC_DIST_TOOLKIT
+#ifdef SILC_DIST_TOOLKIT
 include_HEADERS =      \
        aes.h           \
        blowfish.h      \
@@ -56,9 +54,7 @@ include_HEADERS =     \
        ciphers.h       \
        md5.h           \
        none.h          \
-       pkcs1.h         \
        rc5.h           \
-       rc6.h           \
        rsa.h           \
        sha1.h          \
        silccipher.h    \
@@ -67,10 +63,13 @@ include_HEADERS =   \
        silchmac.h      \
        silcpkcs.h      \
        silcrng.h       \
+       silcpkcs1.h     \
        twofish.h
-endif
 
-EXTRA_DIST = *.h tests
+SILC_EXTRA_DIST = tests
+#endif SILC_DIST_TOOLKIT
+
+EXTRA_DIST = *.h $(SILC_EXTRA_DIST)
 
 include $(top_srcdir)/Makefile.defines.in