Merged silc_1_0_branch to trunk.
[silc.git] / lib / silccore / Makefile.am
index bf01a0f103df4ebdcc71d0a07aa6878736944687..7dae40126f105118794fa04d60a7521451d95abb 100644 (file)
@@ -3,12 +3,11 @@
 #
 #  Author: Pekka Riikonen <priikone@poseidon.pspt.fi>
 #
-#  Copyright (C) 2000 Pekka Riikonen
+#  Copyright (C) 2000 - 2003 Pekka Riikonen
 #
 #  This program is free software; you can redistribute it and/or modify
 #  it under the terms of the GNU General Public License as published by
-#  the Free Software Foundation; either version 2 of the License, or
-#  (at your option) any later version.
+#  the Free Software Foundation; version 2 of the License.
 #
 #  This program is distributed in the hope that it will be useful,
 #  but WITHOUT ANY WARRANTY; without even the implied warranty of
 
 AUTOMAKE_OPTIONS = 1.0 no-dependencies foreign
 
-noinst_LIBRARIES = libsilccore.a
+noinst_LTLIBRARIES = libsilccore.la
 
-libsilccore_a_SOURCES = \
+libsilccore_la_SOURCES = \
        silcid.c \
        silcidcache.c \
+       silcmessage.c \
        silcchannel.c \
        silccommand.c \
        silcpacket.c \
        silcargument.c \
        silcnotify.c \
        silcauth.c \
-       silcprivate.c
+       silcattrs.c \
+       silcstatus.c
 
 if SILC_DIST_TOOLKIT
 include_HEADERS =      \
        silcauth.h      \
        silcchannel.h   \
+       silcmessage.h   \
        silccommand.h   \
        silcidcache.h   \
        silcid.h        \
@@ -42,9 +44,10 @@ include_HEADERS =    \
        silcnotify.h    \
        silcpacket.h    \
        silcargument.h  \
-       silcprivate.h
+       silcstatus.h    \
+       silcattrs.h
 endif
 
-EXTRA_DIST = *.h
+EXTRA_DIST = *.h tests
 
 include $(top_srcdir)/Makefile.defines.in