Merged silc_1_0_branch to trunk.
[silc.git] / lib / silccore / Makefile.am
index 920b7c88354daf788349ea24801d3c6cb65b9dd5..7dae40126f105118794fa04d60a7521451d95abb 100644 (file)
@@ -3,7 +3,7 @@
 #
 #  Author: Pekka Riikonen <priikone@poseidon.pspt.fi>
 #
-#  Copyright (C) 2000 - 2002 Pekka Riikonen
+#  Copyright (C) 2000 - 2003 Pekka Riikonen
 #
 #  This program is free software; you can redistribute it and/or modify
 #  it under the terms of the GNU General Public License as published by
 
 AUTOMAKE_OPTIONS = 1.0 no-dependencies foreign
 
-noinst_LIBRARIES = libsilccore.a
+noinst_LTLIBRARIES = libsilccore.la
 
-libsilccore_a_SOURCES = \
+libsilccore_la_SOURCES = \
        silcid.c \
        silcidcache.c \
+       silcmessage.c \
        silcchannel.c \
        silccommand.c \
        silcpacket.c \
@@ -29,12 +30,13 @@ libsilccore_a_SOURCES = \
        silcnotify.c \
        silcauth.c \
        silcattrs.c \
-       silcprivate.c
+       silcstatus.c
 
 if SILC_DIST_TOOLKIT
 include_HEADERS =      \
        silcauth.h      \
        silcchannel.h   \
+       silcmessage.h   \
        silccommand.h   \
        silcidcache.h   \
        silcid.h        \
@@ -43,10 +45,9 @@ include_HEADERS =    \
        silcpacket.h    \
        silcargument.h  \
        silcstatus.h    \
-       silcattrs.h     \
-       silcprivate.h
+       silcattrs.h
 endif
 
-EXTRA_DIST = *.h
+EXTRA_DIST = *.h tests
 
 include $(top_srcdir)/Makefile.defines.in