Merged silc_1_0_branch to trunk.
[silc.git] / lib / silccore / Makefile.ad
similarity index 82%
rename from lib/silccore/Makefile.am
rename to lib/silccore/Makefile.ad
index 7dae40126f105118794fa04d60a7521451d95abb..b5d6d71b277bed0a82eb8adf351016f4d481173d 100644 (file)
@@ -1,9 +1,9 @@
 #
-#  Makefile.am
+#  Makefile.ad
 #
-#  Author: Pekka Riikonen <priikone@poseidon.pspt.fi>
+#  Author: Pekka Riikonen <priikone@silcnet.org>
 #
-#  Copyright (C) 2000 - 2003 Pekka Riikonen
+#  Copyright (C) 2000 - 2005 Pekka Riikonen
 #
 #  This program is free software; you can redistribute it and/or modify
 #  it under the terms of the GNU General Public License as published by
@@ -32,7 +32,7 @@ libsilccore_la_SOURCES = \
        silcattrs.c \
        silcstatus.c
 
-if SILC_DIST_TOOLKIT
+#ifdef SILC_DIST_TOOLKIT
 include_HEADERS =      \
        silcauth.h      \
        silcchannel.h   \
@@ -46,8 +46,10 @@ include_HEADERS =    \
        silcargument.h  \
        silcstatus.h    \
        silcattrs.h
-endif
 
-EXTRA_DIST = *.h tests
+SILC_EXTRA_DIST = tests
+#endif SILC_DIST_TOOLKIT
+
+EXTRA_DIST = *.h $(SILC_EXTRA_DIST)
 
 include $(top_srcdir)/Makefile.defines.in