updates.
[silc.git] / lib / silcclient / Makefile.am
index 07df38868eb88168e429badd02bd3316bdf437e9..43032ca38ebf3dd93443e18de2e264423877a318 100644 (file)
@@ -22,14 +22,23 @@ noinst_LIBRARIES = libsilcclient.a
 
 libsilcclient_a_SOURCES = \
        client.c \
+       client_keyagr.c \
+       client_notify.c \
+       client_prvmsg.c \
+       client_channel.c \
        command.c \
        command_reply.c \
        idlist.c \
        protocol.c
 
+include_HEADERS=       \
+       client.h        \
+       command.h       \
+       command_reply.h \
+       idlist.h        \
+       protocol.h      \
+       silcapi.h
+
 EXTRA_DIST = *.h
 
-INCLUDES = -I. -I.. -I../silccore -I../silccrypt -I../silcutil \
-       -I../silcmath -I../silcske -I../silcsim \
-       -I../../includes \
-       -I../silcmath/gmp -I../trq
+include $(top_srcdir)/Makefile.defines.in