Merged silc_1_0_branch to trunk.
[silc.git] / lib / silcclient / Makefile.ad
similarity index 76%
rename from lib/silcclient/Makefile.am
rename to lib/silcclient/Makefile.ad
index 103e09e59bb1d61541d7489cbd7ff9bd0e5e60bd..b85ac5a9f083af64a9c746681ad9cfa08c4ddbfc 100644 (file)
@@ -1,14 +1,13 @@
 #
 #  Makefile.am
 #
-#  Author: Pekka Riikonen <priikone@poseidon.pspt.fi>
+#  Author: Pekka Riikonen <priikone@silcnet.org>
 #
-#  Copyright (C) 2000 Pekka Riikonen
+#  Copyright (C) 2000 - 2005 Pekka Riikonen
 #
 #  This program is free software; you can redistribute it and/or modify
 #  it under the terms of the GNU General Public License as published by
-#  the Free Software Foundation; either version 2 of the License, or
-#  (at your option) any later version.
+#  the Free Software Foundation; version 2 of the License.
 #
 #  This program is distributed in the hope that it will be useful,
 #  but WITHOUT ANY WARRANTY; without even the implied warranty of
@@ -34,7 +33,7 @@ libsilcclient_la_SOURCES = \
        idlist.c \
        protocol.c
 
-if SILC_DIST_TOOLKIT
+#ifdef SILC_DIST_TOOLKIT
 include_HEADERS=       \
        client.h        \
        command.h       \
@@ -42,8 +41,10 @@ include_HEADERS=     \
        idlist.h        \
        protocol.h      \
        silcclient.h
-endif
 
-EXTRA_DIST = *.h client_ops_example.c
+SILC_EXTRA_DIST = client_ops_example.c
+#endif SILC_DIST_TOOLKIT
+
+EXTRA_DIST = *.h $(SILC_EXTRA_DIST)
 
 include $(top_srcdir)/Makefile.defines.in