Removed need for GNU Libidn, included simple stringprep from libidn
[silc.git] / lib / contrib / Makefile.am
index 6386103e45e42a81804bd2284133a75fa7a7d374..e204a5f82a78b8a0d3616fbccaacd094e0833f07 100644 (file)
@@ -1,14 +1,13 @@
 #
 #  Makefile.am
 #
-#  Author: Pekka Riikonen <priikone@poseidon.pspt.fi>
+#  Author: Pekka Riikonen <priikone@silcnet.org>
 #
-#  Copyright (C) 2000 Pekka Riikonen
+#  Copyright (C) 2000 - 2005 Pekka Riikonen
 #
 #  This program is free software; you can redistribute it and/or modify
 #  it under the terms of the GNU General Public License as published by
-#  the Free Software Foundation; either version 2 of the License, or
-#  (at your option) any later version.
+#  the Free Software Foundation; version 2 of the License.
 #
 #  This program is distributed in the hope that it will be useful,
 #  but WITHOUT ANY WARRANTY; without even the implied warranty of
 
 AUTOMAKE_OPTIONS = 1.0 no-dependencies foreign
 
-if HAVE_GETOPT_LONG
-if HAVE_REGEX
-noinst_LTLIBRARIES =
-else
-noinst_LTLIBRARIES = libcontrib.la
-endif
-else
 noinst_LTLIBRARIES = libcontrib.la
-endif
-
 
 if HAVE_GETOPT_LONG
 GETOPT =
@@ -44,13 +34,7 @@ endif
 if SILC_WIN32
 libcontrib_la_SOURCES =
 else
-libcontrib_la_SOURCES = \
-       $(GETOPT) \
-       $(REGEX)
-endif
-
-if SILC_DIST_TOOLKIT
-include_HEADERS = getopt.h regex.h
+libcontrib_la_SOURCES = nfkc.c rfc3454.c stringprep.c $(GETOPT) $(REGEX)
 endif
 
 EXTRA_DIST = *.c *.h