Added shared library compilation support.
[silc.git] / lib / contrib / Makefile.am
index 0c3ec06d8b83037cce2a357da4562bfcc5b74d14..b7bec728e1b63e1d8a01b34e39adf8a95b428f6e 100644 (file)
@@ -18,7 +18,7 @@
 
 AUTOMAKE_OPTIONS = 1.0 no-dependencies foreign
 
-noinst_LIBRARIES = libcontrib.a
+noinst_LTLIBRARIES = libcontrib.la
 
 if HAVE_GETOPT_LONG
 GETOPT =
@@ -33,9 +33,9 @@ REGEX = regex.c
 endif
 
 if SILC_WIN32
-libcontrib_a_SOURCES =
+libcontrib_la_SOURCES =
 else
-libcontrib_a_SOURCES = \
+libcontrib_la_SOURCES = \
        $(GETOPT) \
        $(REGEX)
 endif