Merged silc_1_0_branch to trunk.
[silc.git] / lib / contrib / Makefile.am
index b7bec728e1b63e1d8a01b34e39adf8a95b428f6e..74faaf72f5c3c2496684e4d6f0337fa34ea2aab5 100644 (file)
@@ -1,14 +1,13 @@
 #
 #  Makefile.am
 #
-#  Author: Pekka Riikonen <priikone@poseidon.pspt.fi>
+#  Author: Pekka Riikonen <priikone@silcnet.org>
 #
-#  Copyright (C) 2000 Pekka Riikonen
+#  Copyright (C) 2000 - 2005 Pekka Riikonen
 #
 #  This program is free software; you can redistribute it and/or modify
 #  it under the terms of the GNU General Public License as published by
-#  the Free Software Foundation; either version 2 of the License, or
-#  (at your option) any later version.
+#  the Free Software Foundation; version 2 of the License.
 #
 #  This program is distributed in the hope that it will be useful,
 #  but WITHOUT ANY WARRANTY; without even the implied warranty of
@@ -32,16 +31,12 @@ else
 REGEX = regex.c
 endif
 
+STRINGPREP = nfkc.c rfc3454.c stringprep.c
+
 if SILC_WIN32
-libcontrib_la_SOURCES =
+libcontrib_la_SOURCES = $(STRINGPREP)
 else
-libcontrib_la_SOURCES = \
-       $(GETOPT) \
-       $(REGEX)
-endif
-
-if SILC_DIST_TOOLKIT
-include_HEADERS = getopt.h regex.h
+libcontrib_la_SOURCES = $(STRINGPREP) $(GETOPT) $(REGEX)
 endif
 
 EXTRA_DIST = *.c *.h