Merged silc_1_0_branch to trunk.
[silc.git] / lib / contrib / Makefile.am
index 343a02e8ffbb0f2f3b219fa1f69dbc5e5a3f368a..74faaf72f5c3c2496684e4d6f0337fa34ea2aab5 100644 (file)
@@ -1,14 +1,13 @@
 #
 #  Makefile.am
 #
-#  Author: Pekka Riikonen <priikone@poseidon.pspt.fi>
+#  Author: Pekka Riikonen <priikone@silcnet.org>
 #
-#  Copyright (C) 2000 Pekka Riikonen
+#  Copyright (C) 2000 - 2005 Pekka Riikonen
 #
 #  This program is free software; you can redistribute it and/or modify
 #  it under the terms of the GNU General Public License as published by
-#  the Free Software Foundation; either version 2 of the License, or
-#  (at your option) any later version.
+#  the Free Software Foundation; version 2 of the License.
 #
 #  This program is distributed in the hope that it will be useful,
 #  but WITHOUT ANY WARRANTY; without even the implied warranty of
 
 AUTOMAKE_OPTIONS = 1.0 no-dependencies foreign
 
-noinst_LIBRARIES = libcontrib.a
+noinst_LTLIBRARIES = libcontrib.la
 
-libcontrib_a_SOURCES = \
-       getopt.c \
-       getopt1.c
+if HAVE_GETOPT_LONG
+GETOPT =
+else
+GETOPT = getopt.c getopt1.c
+endif
 
-EXTRA_DIST = *.h
+if HAVE_REGEX
+REGEX =
+else
+REGEX = regex.c
+endif
 
-INCLUDES = -I. -I.. -I../silccrypt -I../silcmath -I../silcske \
-       -I../silcsim -I../.. -I../../includes -I../silccore \
-       -I../silcmath/gmp
+STRINGPREP = nfkc.c rfc3454.c stringprep.c
+
+if SILC_WIN32
+libcontrib_la_SOURCES = $(STRINGPREP)
+else
+libcontrib_la_SOURCES = $(STRINGPREP) $(GETOPT) $(REGEX)
+endif
+
+EXTRA_DIST = *.c *.h
+
+include $(top_srcdir)/Makefile.defines.in