Merged silc_1_0_branch to trunk.
[silc.git] / apps / silcd / Makefile.am
index f8d3246c609ec3fc4863dbe2583066cc482f9607..d166e1fb1fd97906c0a210a2e53eb874036c00f0 100644 (file)
@@ -1,14 +1,13 @@
 #
 #  Makefile.am
 #
-#  Author: Pekka Riikonen <priikone@poseidon.pspt.fi>
+#  Author: Pekka Riikonen <priikone@silcnet.org>
 #
-#  Copyright (C) 2000 Pekka Riikonen
+#  Copyright (C) 2000 - 2005 Pekka Riikonen
 #
 #  This program is free software; you can redistribute it and/or modify
 #  it under the terms of the GNU General Public License as published by
-#  the Free Software Foundation; either version 2 of the License, or
-#  (at your option) any later version.
+#  the Free Software Foundation; version 2 of the License.
 #
 #  This program is distributed in the hope that it will be useful,
 #  but WITHOUT ANY WARRANTY; without even the implied warranty of
@@ -23,20 +22,23 @@ sbin_PROGRAMS = silcd
 silcd_SOURCES = \
        protocol.c \
        route.c \
-       server.c \
        packet_send.c \
        packet_receive.c \
        idlist.c \
        command.c \
        command_reply.c \
+       silcd.c \
+       server.c \
+       server_util.c \
+       server_backup.c \
        serverconfig.c \
+       server_query.c \
        serverid.c \
-       silcd.c \
        server_version.c
-silcd_DEPENDENCIES = ../lib/libsilc.a
 
-LDADD = -L. $(SILC_COMMON_LIBS)
+LIBS = $(SILC_COMMON_LIBS) -lsilc
+LDADD =
 
 EXTRA_DIST = *.h
 
-include $(top_srcdir)/Makefile.defines
+include $(top_srcdir)/Makefile.defines.in