Merged silc_1_0_branch to trunk.
[silc.git] / apps / silcd / Makefile.am
index 3322c946c71ce69a95d1a4e0a521a8a4f75f8768..d166e1fb1fd97906c0a210a2e53eb874036c00f0 100644 (file)
@@ -1,14 +1,13 @@
 #
 #  Makefile.am
 #
-#  Author: Pekka Riikonen <priikone@poseidon.pspt.fi>
+#  Author: Pekka Riikonen <priikone@silcnet.org>
 #
-#  Copyright (C) 2000 Pekka Riikonen
+#  Copyright (C) 2000 - 2005 Pekka Riikonen
 #
 #  This program is free software; you can redistribute it and/or modify
 #  it under the terms of the GNU General Public License as published by
-#  the Free Software Foundation; either version 2 of the License, or
-#  (at your option) any later version.
+#  the Free Software Foundation; version 2 of the License.
 #
 #  This program is distributed in the hope that it will be useful,
 #  but WITHOUT ANY WARRANTY; without even the implied warranty of
@@ -33,12 +32,11 @@ silcd_SOURCES = \
        server_util.c \
        server_backup.c \
        serverconfig.c \
+       server_query.c \
        serverid.c \
        server_version.c
 
-silcd_DEPENDENCIES = ../lib/libsilc.a
-
-LIBS = $(SILC_COMMON_LIBS)
+LIBS = $(SILC_COMMON_LIBS) -lsilc
 LDADD =
 
 EXTRA_DIST = *.h