Merged silc_1_1_branch to trunk.
[silc.git] / apps / irssi / src / perl / Makefile.am
index ac8fa7e7f47d22d900d1e045216e28e4fcb8f08a..43a6a341ad6813834aba498830cf0d0bab067f44 100644 (file)
@@ -2,9 +2,16 @@ LIBTOOL = $(PERL_LIBTOOL)
 
 include $(top_srcdir)/Makefile.defines.in
 
-moduledir = $(silc_modulesdir)
+moduledir = @SILC_IRSSIDIR@
 
+if SILCPLUGIN
+perl_dirs = silc
+SCRIPTDIR="$(datadir)/irssi/scripts"
+else
 perl_dirs = common ui textui silc
+SCRIPTDIR="$(datadir)/silc/scripts"
+endif
+
 
 module_LTLIBRARIES = $(perl_module_lib) $(perl_module_fe_lib)
 noinst_LTLIBRARIES = $(perl_static_lib) $(perl_static_fe_lib)
@@ -12,18 +19,18 @@ EXTRA_LTLIBRARIES = \
        libperl_core.la libfe_perl.la \
        libperl_core_static.la libfe_perl_static.la
 
-libperl_core_la_LDFLAGS = -avoid-version -rpath $(moduledir)
-libfe_perl_la_LDFLAGS = -avoid-version -rpath $(moduledir)
+libperl_core_la_LDFLAGS = -module -avoid-version -rpath $(moduledir)
+libfe_perl_la_LDFLAGS = -module -avoid-version -rpath $(moduledir)
 
 perl-core.c: perl-signals-list.h irssi-core.pl.h
 
-INCLUDES = \
+INCLUDES += \
        -I$(top_srcdir)/src \
        -I$(top_srcdir)/src/core \
        -I$(top_srcdir)/src/fe-common/core \
        -I$(top_srcdir)/src/fe-common/silc \
        $(GLIB_CFLAGS) \
-       -DSCRIPTDIR=\""$(datadir)/silc/scripts"\" \
+       -DSCRIPTDIR=\""$(SCRIPTDIR)"\" \
        -DPERL_USE_LIB=\""$(PERL_USE_LIB)"\" \
        -DPERL_STATIC_LIBS=$(PERL_STATIC_LIBS) \
        $(PERL_CFLAGS)
@@ -136,9 +143,10 @@ all-local:
        for dir in $(perl_dirs); do \
          cd $$dir && \
          if [ ! -f Makefile ]; then \
-            $(perlpath) Makefile.PL $(PERL_MM_PARAMS); \
+           $(perlpath) Makefile.PL $(PERL_MM_PARAMS); \
          fi && \
-         ($(MAKE) || $(MAKE)) && \
+         ($(MAKE) CC="$(CC)" CCFLAGS="$(PERL_CFLAGS) $(CFLAGS)" $(PERL_EXTRA_OPTS) || \
+          $(MAKE) CC="$(CC)" CCFLAGS="$(PERL_CFLAGS) $(CFLAGS)" $(PERL_EXTRA_OPTS)) && \
          cd ..; \
        done
 
@@ -156,8 +164,8 @@ clean-generic:
 
 distclean-generic:
        for dir in $(perl_dirs); do \
-         cd $$dir && \
-         $(MAKE) realclean && rm -f Makefile.PL && \
+         cd $$dir; \
+         $(MAKE) realclean; rm -f Makefile.PL Makefile; \
          cd ..; \
        done