Sun May 13 16:54:35 CEST 2007 Jochen Eisinger <coffee@silcnet.org>
[silc.git] / apps / irssi / src / perl / Makefile.am
index ac8fa7e7f47d22d900d1e045216e28e4fcb8f08a..3b978476929d241fe4b62b83ce54430d76cc7dc3 100644 (file)
@@ -12,12 +12,12 @@ EXTRA_LTLIBRARIES = \
        libperl_core.la libfe_perl.la \
        libperl_core_static.la libfe_perl_static.la
 
-libperl_core_la_LDFLAGS = -avoid-version -rpath $(moduledir)
-libfe_perl_la_LDFLAGS = -avoid-version -rpath $(moduledir)
+libperl_core_la_LDFLAGS = -module -avoid-version -rpath $(moduledir)
+libfe_perl_la_LDFLAGS = -module -avoid-version -rpath $(moduledir)
 
 perl-core.c: perl-signals-list.h irssi-core.pl.h
 
-INCLUDES = \
+INCLUDES += \
        -I$(top_srcdir)/src \
        -I$(top_srcdir)/src/core \
        -I$(top_srcdir)/src/fe-common/core \
@@ -136,9 +136,10 @@ all-local:
        for dir in $(perl_dirs); do \
          cd $$dir && \
          if [ ! -f Makefile ]; then \
-            $(perlpath) Makefile.PL $(PERL_MM_PARAMS); \
+           $(perlpath) Makefile.PL $(PERL_MM_PARAMS); \
          fi && \
-         ($(MAKE) || $(MAKE)) && \
+         ($(MAKE) CC="$(CC)" CCFLAGS="$(PERL_CFLAGS) $(CFLAGS)" $(PERL_EXTRA_OPTS) || \
+          $(MAKE) CC="$(CC)" CCFLAGS="$(PERL_CFLAGS) $(CFLAGS)" $(PERL_EXTRA_OPTS)) && \
          cd ..; \
        done
 
@@ -156,8 +157,8 @@ clean-generic:
 
 distclean-generic:
        for dir in $(perl_dirs); do \
-         cd $$dir && \
-         $(MAKE) realclean && rm -f Makefile.PL && \
+         cd $$dir; \
+         $(MAKE) realclean; rm -f Makefile.PL Makefile; \
          cd ..; \
        done