Sun May 13 16:54:35 CEST 2007 Jochen Eisinger <coffee@silcnet.org>
[silc.git] / apps / irssi / src / fe-text / Makefile.am
index 2b248696ef2e148489214b41310b217513e9e01a..ebd2053306162d89eb3fdaa7925a76134573d79f 100644 (file)
@@ -2,7 +2,7 @@ bin_PROGRAMS = silc
 
 include $(top_srcdir)/Makefile.defines.in
 
-INCLUDES = \
+INCLUDES += \
        -I$(top_srcdir)/src \
        -I$(top_srcdir)/src/core/ \
        -I$(top_srcdir)/src/fe-common/core/ \
@@ -19,7 +19,7 @@ silc_DEPENDENCIES =           \
 LIBS = $(SILC_COMMON_LIBS)
 silc_LDADD = \
        @COMMON_LIBS@ \
-       -L$(silc_top_srcdir)/lib -lsilcclient \
+       -lsilcclient \
        @PERL_LINK_LIBS@ \
        @PERL_FE_LINK_LIBS@ \
        @PERL_LINK_FLAGS@ \
@@ -37,6 +37,11 @@ terminfo_sources = \
 curses_sources = \
        term-curses.c
 
+cuix_sources = \
+       cuix-api.c \
+       cuix-lib.c \
+       cuix.c
+
 if NEED_TPARM
 use_tparm_sources = $(tparm_sources)
 endif
@@ -47,6 +52,12 @@ else
 use_term_sources = $(terminfo_sources)
 endif
 
+if USE_CUIX
+use_term_sources += $(cuix_sources)
+silc_LDADD += -lform -lpanel -lmenu
+INCLUDES += -I$(top_srcdir)/src/irc/core
+endif
+
 silc_SOURCES = \
         gui-entry.c \
        gui-expandos.c \
@@ -68,7 +79,6 @@ silc_SOURCES = \
         textbuffer-commands.c \
         textbuffer-reformat.c \
         textbuffer-view.c \
-       utf8.c \
         silc.c \
        module-formats.c
 
@@ -85,7 +95,6 @@ noinst_HEADERS = \
         textbuffer.h \
         textbuffer-view.h \
         textbuffer-reformat.h \
-       utf8.h \
        module.h \
        module-formats.h