Merged Irssi SVN (upcoming irssi 0.8.11).
[silc.git] / apps / irssi / src / fe-text / Makefile.am
index 2b248696ef2e148489214b41310b217513e9e01a..a03b15d79872900c50b9574bc1c7135eff1dfa7c 100644 (file)
@@ -37,6 +37,11 @@ terminfo_sources = \
 curses_sources = \
        term-curses.c
 
+cuix_sources = \
+       cuix-api.c \
+       cuix-lib.c \
+       cuix.c
+
 if NEED_TPARM
 use_tparm_sources = $(tparm_sources)
 endif
@@ -47,6 +52,12 @@ else
 use_term_sources = $(terminfo_sources)
 endif
 
+if USE_CUIX
+use_term_sources += $(cuix_sources)
+silc_LDADD += -lform -lpanel -lmenu
+INCLUDES += -I$(top_srcdir)/src/irc/core
+endif
+
 silc_SOURCES = \
         gui-entry.c \
        gui-expandos.c \
@@ -68,7 +79,6 @@ silc_SOURCES = \
         textbuffer-commands.c \
         textbuffer-reformat.c \
         textbuffer-view.c \
-       utf8.c \
         silc.c \
        module-formats.c
 
@@ -85,7 +95,6 @@ noinst_HEADERS = \
         textbuffer.h \
         textbuffer-view.h \
         textbuffer-reformat.h \
-       utf8.h \
        module.h \
        module-formats.h