Merged from silc_1_0_branch.
[silc.git] / apps / irssi / src / fe-text / Makefile.am
index 326eb61801fe4555f379a983327b1ec6608c9c96..02cb3dd807e0caf2caa86bce895c2a587aeb6270 100644 (file)
@@ -2,26 +2,50 @@ bin_PROGRAMS = silc
 
 include $(top_srcdir)/Makefile.defines.in
 
-ADD_INCLUDES = \
-       $(GLIB_CFLAGS) \
+INCLUDES = \
        -I$(top_srcdir)/src \
        -I$(top_srcdir)/src/core/ \
-       -I$(top_srcdir)/src/silc/core/ \
        -I$(top_srcdir)/src/fe-common/core/ \
        -I$(top_srcdir)/src/fe-common/silc/ \
+       $(GLIB_CFLAGS) \
        $(CURSES_INCLUDEDIR) \
        -DLOCALEDIR=\""$(datadir)/locale"\"
 
-silc_DEPENDENCIES = @COMMON_LIBS@
+silc_DEPENDENCIES =            \
+       @COMMON_LIBS@           \
+       @PERL_LINK_LIBS@        \
+       @PERL_FE_LINK_LIBS@
 
 LIBS = $(SILC_COMMON_LIBS)
 silc_LDADD = \
        @COMMON_LIBS@ \
+       -L../../../lib -lsilcclient \
        @PERL_LINK_LIBS@ \
        @PERL_FE_LINK_LIBS@ \
-       $(PROG_LIBS) \
-        $(CURSES_LIBS) \
-       -L../../../lib -lsilcclient
+       @PERL_LINK_FLAGS@ \
+       @PROG_LIBS@     \
+       @TEXTUI_LIBS@
+silc_LDFLAGS = -export-dynamic
+
+tparm_sources = \
+       tparm.c
+
+terminfo_sources = \
+        term-terminfo.c \
+        terminfo-core.c
+
+curses_sources = \
+       term-curses.c
+
+if NEED_TPARM
+use_tparm_sources = $(tparm_sources)
+endif
+
+if USE_CURSES
+use_term_sources = $(curses_sources)
+else
+use_term_sources = $(terminfo_sources)
+endif
 
 silc_SOURCES = \
         gui-entry.c \
@@ -32,13 +56,19 @@ silc_SOURCES = \
        lastlog.c \
         mainwindows.c \
         mainwindow-activity.c \
-        mainwindows-save.c \
-        screen.c \
+        mainwindows-layout.c \
         statusbar.c \
+        statusbar-config.c \
         statusbar-items.c \
+        term.c \
+       term-dummy.c \
+       $(use_tparm_sources) \
+       $(use_term_sources) \
         textbuffer.c \
         textbuffer-commands.c \
+        textbuffer-reformat.c \
         textbuffer-view.c \
+       utf8.c \
         silc.c \
        module-formats.c
 
@@ -49,8 +79,17 @@ noinst_HEADERS = \
         gui-windows.h \
         mainwindows.h \
         statusbar.h \
-        screen.h \
+        statusbar-config.h \
+       term.h \
+       terminfo-core.h \
         textbuffer.h \
         textbuffer-view.h \
+        textbuffer-reformat.h \
+       utf8.h \
        module.h \
        module-formats.h
+
+EXTRA_DIST = \
+       $(tparm_sources) \
+       $(terminfo_sources) \
+       $(curses_sources)