Merge Irssi 0.8.16-rc1
[silc.git] / apps / irssi / src / fe-text / Makefile.am
index cfa02758a57bb6b8626f6380aeb67be86706469f..2825dd00177e7a37d333e08463da6662109a69fd 100644 (file)
@@ -38,11 +38,6 @@ terminfo_sources = \
 curses_sources = \
        term-curses.c
 
-cuix_sources = \
-       cuix-api.c \
-       cuix-lib.c \
-       cuix.c
-
 if NEED_TPARM
 use_tparm_sources = $(tparm_sources)
 endif
@@ -53,12 +48,6 @@ else
 use_term_sources = $(terminfo_sources)
 endif
 
-if USE_CUIX
-use_term_sources += $(cuix_sources)
-silc_LDADD += -lform -lpanel -lmenu
-INCLUDES += -I$(top_srcdir)/src/irc/core
-endif
-
 silc_SOURCES = \
         gui-entry.c \
        gui-expandos.c \
@@ -78,12 +67,12 @@ silc_SOURCES = \
        $(use_term_sources) \
         textbuffer.c \
         textbuffer-commands.c \
-        textbuffer-reformat.c \
         textbuffer-view.c \
         silc.c \
        module-formats.c
 
 noinst_HEADERS = \
+       statusbar-item.h \
         gui-entry.h \
         gui-printtext.h \
         gui-readline.h \
@@ -95,7 +84,6 @@ noinst_HEADERS = \
        terminfo-core.h \
         textbuffer.h \
         textbuffer-view.h \
-        textbuffer-reformat.h \
        module.h \
        module-formats.h