Sun May 13 16:54:35 CEST 2007 Jochen Eisinger <coffee@silcnet.org>
[silc.git] / apps / irssi / src / fe-common / core / Makefile.am
index 798c271c327cbce84b0e7cc1456651373618bd94..4860da14a32c2ea01fe1e57aa5e81efc1c59064e 100644 (file)
@@ -2,11 +2,11 @@ noinst_LIBRARIES = libfe_common_core.a
 
 include $(top_srcdir)/Makefile.defines.in
 
-INCLUDES = \
-       $(GLIB_CFLAGS) \
+INCLUDES += \
        -I$(top_srcdir)/src -I$(top_srcdir)/src/core/ \
+       $(GLIB_CFLAGS) \
        -DHELPDIR=\""$(silc_helpdir)"\" \
-       -DSYSCONFDIR=\""$(silc_etcdir)"\"
+       -DTHEMESDIR=\""$(silc_etcdir)"\"
 
 libfe_common_core_a_SOURCES = \
        autorun.c \
@@ -27,11 +27,13 @@ libfe_common_core_a_SOURCES = \
        fe-queries.c \
        fe-server.c \
        fe-settings.c \
+       utf8.c \
        formats.c \
        hilight-text.c \
        keyboard.c \
        module-formats.c \
        printtext.c \
+       fe-recode.c \
        themes.c \
        translation.c \
        window-activity.c \
@@ -41,22 +43,27 @@ libfe_common_core_a_SOURCES = \
        fe-windows.c
 
 noinst_HEADERS = \
+       autorun.h \
        command-history.h \
        chat-completion.h \
        completion.h \
        fe-channels.h \
        fe-common-core.h \
+       fe-core-commands.h \
        fe-exec.h \
        fe-messages.h \
        fe-queries.h \
+       utf8.h \
        formats.h \
        hilight-text.h \
        keyboard.h \
        module-formats.h \
        module.h \
        printtext.h \
+       fe-recode.h \
        themes.h \
        translation.h \
+       window-activity.h \
        window-items.h \
        windows-layout.h \
        fe-windows.h