Sun May 13 16:54:35 CEST 2007 Jochen Eisinger <coffee@silcnet.org>
[silc.git] / apps / irssi / src / core / Makefile.am
index 1dc2f5f91ca4f5c66d3bed33dfe5d984b08f3a2d..8c11695fe97581af12547f4c71135aa7dcef6c21 100644 (file)
@@ -1,17 +1,13 @@
 noinst_LIBRARIES = libcore.a
 
-INCLUDES = \
-       $(GLIB_CFLAGS) \
-       -DSYSCONFDIR=\""$(sysconfdir)"\" \
-       -DMODULEDIR=\""$(libdir)/irssi/modules"\" \
-       -I$(top_srcdir)/src \
-       -I$(top_srcdir)/src/core
+include $(top_srcdir)/Makefile.defines.in
 
-if BUILD_MEMDEBUG
-memdebug_src=memdebug.c
-else
-memdebug_src=
-endif
+INCLUDES += \
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/core \
+       $(GLIB_CFLAGS) \
+       -DSYSCONFDIR=\""$(silc_etcdir)"\" \
+       -DMODULEDIR=\""$(silc_modulesdir)"\"
 
 libcore_a_SOURCES = \
        args.c \
@@ -27,23 +23,26 @@ libcore_a_SOURCES = \
         levels.c \
        line-split.c \
        log.c \
+       log-away.c \
        masks.c \
-        $(memdebug_src) \
        misc.c \
        modules.c \
+       modules-load.c \
        net-disconnect.c \
        net-nonblock.c \
        net-sendbuffer.c \
        network.c \
+       network-openssl.c \
        nicklist.c \
        nickmatch-cache.c \
        pidwait.c \
        queries.c \
        rawlog.c \
+       recode.c \
        servers.c \
        servers-reconnect.c \
-       servers-redirect.c \
        servers-setup.c \
+       session.c \
        settings.c \
        signals.c \
        special-vars.c \
@@ -73,10 +72,10 @@ noinst_HEADERS = \
        line-split.h \
        log.h \
        masks.h \
-        memdebug.h \
        misc.h \
        module.h \
        modules.h \
+       modules-load.h \
        net-disconnect.h \
        net-nonblock.h \
        net-sendbuffer.h \
@@ -87,16 +86,14 @@ noinst_HEADERS = \
        pidwait.h \
        queries.h \
        rawlog.h \
+       recode.h \
        servers.h \
        servers-reconnect.h \
-       servers-redirect.h \
        servers-setup.h \
+       session.h \
        settings.h \
        signals.h \
        special-vars.h \
        window-item-def.h \
        write-buffer.h \
        $(structure_headers)
-
-EXTRA_DIST = \
-       memdebug.c