Tue Apr 10 15:55:42 CEST 2007 Jochen Eisinger <coffee@silcnet.org>
[silc.git] / apps / irssi / configure.in
index 68c990a278b88edf185a6c71e2cd477b425e9a8c..c1b1aaf53f345b1100c87d72d8c1b905806a1685 100644 (file)
@@ -189,6 +189,17 @@ AC_ARG_WITH(perl,
        fi,
        want_perl=static)
 
+# Irssi SILC Plugin support
+#
+AC_ARG_ENABLE(silc-plugin,
+[  --enable-silc-plugin    Compile the SILC Plugin instead of the SILC Client],
+[case "${enableval}" in
+  yes) silc_plugin=true ;;
+  no)  silc_plugin=false ;;
+  *) AC_MSG_ERROR(bad value ${enableval} for --enable-silc-plugin) ;;
+esac],[silc_plugin=false])
+AM_CONDITIONAL(SILCPLUGIN, test x$silc_plugin = xtrue)
+
 AC_ARG_WITH(file-offset-size,
 [  --with-file-offset-size=BITS  Set size of file offsets. Usually 32 or 64.
                           (default: 64 if available)],