Libtool 2.x support
[silc.git] / apps / irssi / configure.in
index 68c990a278b88edf185a6c71e2cd477b425e9a8c..755fb1bf616bceb81fefa43d34500e045da6e83d 100644 (file)
@@ -1,4 +1,4 @@
-AC_INIT(src)
+AC_INIT([SILC-Client], [0.8.11+], [silc-devel@lists.silcnet.org], [silc-client])
 
 # we don't want VERSION in our config.h
 if test -n "`grep '^#undef VERSION' config.h.in`"; then
@@ -7,7 +7,7 @@ if test -n "`grep '^#undef VERSION' config.h.in`"; then
 fi
 
 AM_CONFIG_HEADER(config.h)
-AM_INIT_AUTOMAKE(SILC-Client, 0.8.11+)
+AM_INIT_AUTOMAKE
 
 AM_MAINTAINER_MODE
 
@@ -15,7 +15,8 @@ AC_ISC_POSIX
 AC_PROG_CC
 AC_PROG_CPP
 AC_STDC_HEADERS
-AM_PROG_LIBTOOL
+LT_INIT
+LT_OUTPUT
 
 AC_PATH_PROG(sedpath, sed)
 AC_PATH_PROG(perlpath, perl)
@@ -189,6 +190,36 @@ AC_ARG_WITH(perl,
        fi,
        want_perl=static)
 
+# Irssi SILC Plugin support
+#
+SILC_IRSSIDIR=
+silc_plugin=false
+AC_MSG_CHECKING(whether to compile SILC Plugin for Irssi)
+AC_ARG_WITH(silc-plugin,
+  [[  --with-silc-plugin[=DIR] Compile the SILC Plugin for Irssi, specify
+                           Irssi location [/usr/lib/irssi]]],
+  [
+    case "${withval}" in
+      no)
+        AC_MSG_RESULT(no)
+        silc_plugin=false
+        ;;
+      yes)
+        AC_MSG_RESULT(yes)
+        silc_plugin=true
+       SILC_IRSSIDIR="/usr/lib/irssi/modules"
+       ;;
+      *)
+        AC_MSG_RESULT(yes)
+        silc_plugin=true
+        SILC_IRSSIDIR="$withval/modules"
+        ;;
+    esac
+  ])
+
+AM_CONDITIONAL(SILCPLUGIN, test x$silc_plugin = xtrue)
+AC_SUBST(SILC_IRSSIDIR)
+
 AC_ARG_WITH(file-offset-size,
 [  --with-file-offset-size=BITS  Set size of file offsets. Usually 32 or 64.
                           (default: 64 if available)],
@@ -462,27 +493,15 @@ cat > conftest.c <<EOF
 int modfunc(){return (int)floor(1.2);}
 EOF
 
-./libtool --mode=compile $CC $CFLAGS -c conftest.c 2> /dev/null > /dev/null
-if test ! -s conftest.lo; then
-  AC_ERROR([error compiling test module])
-fi
-
-dnl ** link to library
-./libtool --mode=link $CC $CFLAGS $LDFLAGS -rpath /usr/lib conftest.lo -lm -o libconftest.la > /dev/null
-if test ! -s .libs/libconftest.a; then
-  AC_ERROR([error, can't even find .a library])
-fi
-
-dnl ** check if dynamic linking worked
-libfile=`grep '^library_names' libconftest.la|$sedpath "s/library_names='\(.*\)'.*/\1/"|$sedpath 's/.* \([[^ ]]*\)$/\1/'`
-if test ! -s .libs/$libfile; then
-  AC_MSG_RESULT([no, error linking test module])
+if ! ./libtool --tag=CC --mode=compile $CC $CFLAGS -c conftest.c >/dev/null 2>&1 || \
+   ! ./libtool --tag=CC --mode=link $CC $CFLAGS $LDFLAGS -rpath /usr/lib conftest.lo -lm -o libconftest.la >/dev/null 2>&1; then
+  AC_MSG_RESULT([no, error compiling test module])
 else
   cat > conftest.c <<EOF
 #include <gmodule.h>
 main() {
 GModule *m; int (*modfunc)(void);
-m = g_module_open(".libs/$libfile", 0);
+m = g_module_open("libconftest.la", 0);
 if (!m) g_print("error loading: %s", g_module_error());
 else if (!g_module_symbol(m, "modfunc", (gpointer *) &modfunc))
   g_print("modfunc() symbol not found from module");
@@ -867,7 +886,6 @@ docs/help/Makefile
 docs/help/in/Makefile
 irssi-version.h
 stamp.h
-irssi.spec
 irssi-config)
 
 dnl ** for building from objdir