Merged silc_1_1_branch to trunk.
[silc.git] / apps / irssi / Makefile.am
index 9c5f102e60875ebfd006872370139ffcb9b36139..a5fd056def06bd10e2868b4868f3b792b32b7e0d 100644 (file)
@@ -23,10 +23,11 @@ conffile = silc.conf
 
 if SILCPLUGIN
 themedir = $(datadir)/irssi/themes
+theme_DATA = plugin.theme
 else
 themedir = $(datadir)/silc/themes
+theme_DATA = default.theme plugin.theme
 endif
-theme_DATA = default.theme
 
 noinst_HEADERS = irssi-version.h.in
 
@@ -35,8 +36,7 @@ EXTRA_DIST = \
        curses.m4 \
        README \
        file2header.sh \
-       irssi.spec \
-       irssi.spec.in \
+       silc-client.spec \
        $(conffile) \
        $(theme_DATA) \
        irssi-config.in \
@@ -51,7 +51,7 @@ rpm: Makefile
        rpm -ta --clean $(PACKAGE)-$(VERSION).tar.gz
 
 install-dirs-client:
-       -mkdir -p $(helpdir)
+       -mkdir -p $(docdir)
        -mkdir -p $(mandir)/man1
 
 doc-install-client: