Merged silc_1_1_branch to trunk.
[silc.git] / apps / irssi / Makefile.am
index 0233e8e10daf73febfca48fec90a9943593c4cee..a5fd056def06bd10e2868b4868f3b792b32b7e0d 100644 (file)
@@ -21,8 +21,13 @@ include $(top_srcdir)/Makefile.defines.in
 confdir = $(silc_etcdir)
 conffile = silc.conf
 
+if SILCPLUGIN
+themedir = $(datadir)/irssi/themes
+theme_DATA = plugin.theme
+else
 themedir = $(datadir)/silc/themes
-theme_DATA = default.theme
+theme_DATA = default.theme plugin.theme
+endif
 
 noinst_HEADERS = irssi-version.h.in
 
@@ -31,8 +36,7 @@ EXTRA_DIST = \
        curses.m4 \
        README \
        file2header.sh \
-       irssi.spec \
-       irssi.spec.in \
+       silc-client.spec \
        $(conffile) \
        $(theme_DATA) \
        irssi-config.in \
@@ -47,7 +51,7 @@ rpm: Makefile
        rpm -ta --clean $(PACKAGE)-$(VERSION).tar.gz
 
 install-dirs-client:
-       -mkdir -p $(helpdir)
+       -mkdir -p $(docdir)
        -mkdir -p $(mandir)/man1
 
 doc-install-client:
@@ -58,7 +62,7 @@ doc-install-client:
 
 etc-install-client:
        -@if test -d $(silc_top_srcdir)/apps/irssi ; then \
-         -mkdir -p $(etcdir) \
+         mkdir -p $(etcdir) ; \
          if test '!' -f $(etcdir)/silc.conf ; then \
            $(INSTALL_DATA) $(silc_top_srcdir)/apps/irssi/silc.conf \
                $(etcdir)/silc.conf; \
@@ -66,12 +70,12 @@ etc-install-client:
        fi
 
 if SILCPLUGIN
-ETCINSTALL=etc-install-client
-else
 ETCINSTALL=
+else
+ETCINSTALL=etc-install-client
 endif
 
 install-data-hook:             \
        install-dirs-client     \
        doc-install-client      \
-       etc-install-client
+       $(ETCINSTALL)