Added SILC Buffer Stream API
[runtime.git] / lib / silcutil / tests / Makefile.am
index e0025733ca7578c29af6defb258a0d749c9fa8c8..ceade7d458d5f6b2fb5e6d130be76b55ded0150f 100644 (file)
@@ -3,7 +3,7 @@
 #
 #  Author: Pekka Riikonen <priikone@silcnet.org>
 #
-#  Copyright (C) 2004 - 2005 Pekka Riikonen
+#  Copyright (C) 2004 - 2008 Pekka Riikonen
 #
 #  This program is free software; you can redistribute it and/or modify
 #  it under the terms of the GNU General Public License as published by
 
 AUTOMAKE_OPTIONS = 1.0 no-dependencies foreign
 
-bin_PROGRAMS =         test_silcstrutil test_silcstringprep test_silchashtable
+check_PROGRAMS = \
+       test_silcstrutil test_silcstringprep test_silchashtable \
+       test_silclist test_silcfsm test_silcasync test_silcschedule \
+       test_silcnet test_silcstack test_silcmime test_silcfdstream \
+       test_silcatomic test_silcmutex test_silctime test_silcthread \
+       test_silcdll test_silcenv test_silctimer test_silcbitops \
+       test_silcregex test_silcbuffmt test_silcdir test_silcthreadqueue \
+       test_silcrand test_silcglobal test_silcbufferstream
 
-test_silcstrutil_SOURCES = test_silcstrutil.c
-test_silcstringprep_SOURCES = test_silcstringprep.c
-test_silchashtable_SOURCES = test_silchashtable.c
+TESTS = test_silcstrutil test_silcstringprep test_silchashtable \
+       test_silclist test_silcfsm test_silcasync test_silcschedule \
+       test_silcnet test_silcstack test_silcmime test_silcfdstream \
+       test_silcatomic test_silctime test_silcthread \
+       test_silcdll test_silcenv test_silctimer test_silcbitops \
+       test_silcregex test_silcbuffmt test_silcdir test_silcthreadqueue \
+       test_silcrand test_silcglobal test_silcbufferstream
 
 LIBS = $(SILC_COMMON_LIBS)
-LDADD = -L.. -L../.. -lsilc
+LDADD = -L.. -L../.. -lsrt
 
 include $(top_srcdir)/Makefile.defines.in