Major restructuring of the internals of SILC Cipher API
[crypto.git] / lib / silccrypt / tests / Makefile.am
index 838a57c3c10112f06b44ab1f0d95edf571d80f53..9e86175b65b87e75f8aa1c7fe6c4a23853c5a071 100644 (file)
@@ -29,7 +29,8 @@ bin_PROGRAMS =        test_sha1       \
                test_des        \
                test_silcpkcs   \
                test_dsa        \
-               test_hash
+               test_hash       \
+               test_cipher
 
 test_hash_SOURCES = test_hash.c
 test_sha1_SOURCES = test_sha1.c
@@ -39,6 +40,7 @@ test_hmacsha1_SOURCES = test_hmacsha1.c
 test_hmacsha256_SOURCES = test_hmacsha256.c
 test_hmacmd5_SOURCES = test_hmacmd5.c
 
+test_cipher_SOURCES = test_cipher.c
 test_aes_SOURCES = test_aes.c
 test_twofish_SOURCES = test_twofish.c
 test_cast5_SOURCES = test_cast5.c
@@ -48,6 +50,6 @@ test_silcpkcs_SOURCES = test_silcpkcs.c
 test_dsa_SOURCES = test_dsa.c
 
 LIBS = $(SILC_COMMON_LIBS)
-LDADD = -L.. -L../.. -lsilc
+LDADD = -L.. -L../.. -lsct
 
 include $(top_srcdir)/Makefile.defines.in