Major restructuring of the internals of SILC Cipher API
[crypto.git] / lib / silccrypt / tests / Makefile.am
index 0182587224ba63f5e5f0c15cea4d924a32466238..9e86175b65b87e75f8aa1c7fe6c4a23853c5a071 100644 (file)
@@ -26,8 +26,13 @@ bin_PROGRAMS =       test_sha1       \
                test_aes        \
                test_twofish    \
                test_cast5      \
-               test_silcpkcs
+               test_des        \
+               test_silcpkcs   \
+               test_dsa        \
+               test_hash       \
+               test_cipher
 
+test_hash_SOURCES = test_hash.c
 test_sha1_SOURCES = test_sha1.c
 test_sha256_SOURCES = test_sha256.c
 test_md5_SOURCES = test_md5.c
@@ -35,13 +40,16 @@ test_hmacsha1_SOURCES = test_hmacsha1.c
 test_hmacsha256_SOURCES = test_hmacsha256.c
 test_hmacmd5_SOURCES = test_hmacmd5.c
 
+test_cipher_SOURCES = test_cipher.c
 test_aes_SOURCES = test_aes.c
 test_twofish_SOURCES = test_twofish.c
 test_cast5_SOURCES = test_cast5.c
+test_des_SOURCES = test_des.c
 
 test_silcpkcs_SOURCES = test_silcpkcs.c
+test_dsa_SOURCES = test_dsa.c
 
 LIBS = $(SILC_COMMON_LIBS)
-LDADD = -L.. -L../.. -lsilc
+LDADD = -L.. -L../.. -lsct
 
 include $(top_srcdir)/Makefile.defines.in